Skip to main content

Ralsina.Me — Roberto Alsina's website

Rebelling against insanity: Wicd requires half of GNOME

UP­DATE: you can get this pro­gram now at google code

I have been us­ing my eee for a while al­ready with a sort of Kubun­tu in it.

How­ev­er, my favourite wire­less/wired net­work man­age­ment app is wicd, which is a Python/GTK ap­pli­ca­tion. Or was, since ver­sion 1.4.1 re­quires python-g­nome2-ex­tras.

Which de­pends on ....

libart-2.0-2 (>= 2.3.18), libaspell15 (>= 0.60), libatk1.0-0 (>= 1.13.2), libbonobo2-0 (>= 2.15.0),
libbonoboui2-0 (>= 2.15.1), libc6 (>= 2.6-1), libcairo2 (>= 1.4.0),
libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgconf2-4 (>= 2.13.5),
libgda3-3, libgdl-1-0, libgdl-gnome-1-0, libgksu1.2-1 (>= 1.3.3), libgksu2-0 (>= 1.9.6),
libgksuui1.0-1, libglade2-0 (>= 1:2.6.1), libglib2.0-0 (>= 2.14.0), libgnome-keyring0 (>= 2.19.6),
libgnome2-0 (>= 2.17.3), libgnomecanvas2-0 (>= 2.11.1), libgnomeui-0 (>= 2.19.1),
libgnomevfs2-0 (>= 1:2.17.90), libgtk2.0-0 (>= 2.12.0), libgtkspell0 (>= 2.0.2),
libice6 (>= 1:1.0.0), libnspr4-0d (>= 1.8.0.10), liborbit2 (>= 1:2.14.8),
libpango1.0-0 (>= 1.18.2), libpng12-0 (>= 1.2.13-4), libpopt0 (>= 1.10), libsm6,
libstartup-notification0 (>= 0.8-1), libx11-6, libxcomposite1 (>=1:0.3-1),
libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3 (>= 1:4.0.1), libxi6, libxinerama1,
libxml2 (>= 2.6.29), libxrandr2 (>= 2:1.2.0), libxrender1, zlib1g (>= 1:1.2.3.3.dfsg-1),
python-support (>= 0.3.4), python (<< 2.6), python (>= 2.4), python-gtk2,
python-pyorbit, python-gnome2-desktop

In short: a 87MB down­load. That can't be good. In fac­t, there are al­most no changes from 1.3.1 which did­n't re­quire all that! Ex­cept for one change that makes all the dif­fer­ence on a eee PC: ver­ti­cal re­siz­ing to un­der 400px. :-(

So, be­cause I am who I am, I did this:

wicd-qt.png

It's a re­place­ment for wicd's gui.py and tray.py. On­ly needs PyQt4 which I al­ready had and de­pends on:

libc6 (>= 2.6-1), libgcc1 (>= 1:4.2.1), libqt4-core (>= 4.3.2),
libqt4-gui (>= 4.3.2), libstdc++6 (>= 4.2.1), python-central (>= 0.5.8),
python (<< 2.6), python (>= 2.4), python-sip4 (>= 4.7), python-sip4 (<< 4.8)

See a dif­fer­ence there?

Took me about 3 hours to hack to­geth­er, and works (ex­cept for wired con­fig, the prefs di­alog, stat­ic IP and script­s) but the hard work is done.

If any­one wants a copy, just ask. I ex­pect KUbun­tu could use some­thing like it?

Snis / 2008-02-06 19:08:

Yes!
Great work, could I please have a copy of the code. The GUI looks alot better than the GTK one.

keep it up!

Roberto Alsina / 2008-02-07 07:15:

I need to hack a couple more things before it's not too ugly to show :-)

O will put it on a googlecode project on a few days.