Ir al contenido principal

Ralsina.Me — El sitio web de Roberto Alsina

Konq-embed hacking progress

Ok, I have done a lit­tle about that.

Turns out I was patch­ing it for HEAD, not 3_3_1, so I fixed that, and now the avail­able patch­es work for both ver­sion­s.

Of course that does­n't mean ei­ther one ac­tu­al­ly build­s, on­ly that the stuff that need­ed to be patched for 3.2 is now patched for new­er ver­sions as well.

The big­gest prob­lem with this piece of code is that in or­der to do it nice­ly, I have to test ev­ery change I make agains sources pre­pared from 3 dif­fer­ent KDE re­leas­es (or rather, about 5 or 6, but I will not do that), so that when I touch one of the dropin/ class­es to pro­vide a 3.3 in­ter­face, I don break the 3.2 kdesr­c/ build.

And I am oing it in a pret­ty slow box, so each build takes a cou­ple of hours.

Er­go, I am do­ing it wrong. I am go­ing to hack against 3.3.1 un­til it work­s, then 3.2 un­til it work­s, then 3.3.89.

Then all around again, un­til all three work with­out trou­ble. It's not go­ing to be too easy.

To make mat­ters worse, I re­al­ized that I don't need it to work with 3.3 for what I want­ed, since a 3.2-based KHTML is al­ready good enough.

Oh, well, at least I am hack­ing in pub­lic CVS again. Hope­ful­ly I won't break any­thing too bad­ly.


Contents © 2000-2020 Roberto Alsina