Ir al contenido principal

Ralsina.Me — El sitio web de Roberto Alsina

Rebelándose contra la locura: Wicd depende de la mitad de GNOME

Es­toy usan­do mi eee ha­ce ya un tiem­po con una es­pe­cie de Ku­bun­tu.

Sin em­bar­go, mi apli­ca­ción fa­vo­ri­ta pa­ra ma­ne­jar re­des wi­re­le­ss o no es wi­cd, que usa Py­tho­n/­GTK. O usa­ba, ya que la ver­sión 1.4.1 re­quie­re py­tho­n-g­no­me2-ex­tra­s.

Lo que a su vez de­pen­de de...

libart-2.0-2 (>= 2.3.18), libaspell15 (>= 0.60), libatk1.0-0 (>= 1.13.2), libbonobo2-0 (>= 2.15.0),
libbonoboui2-0 (>= 2.15.1), libc6 (>= 2.6-1), libcairo2 (>= 1.4.0),
libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgconf2-4 (>= 2.13.5),
libgda3-3, libgdl-1-0, libgdl-gnome-1-0, libgksu1.2-1 (>= 1.3.3), libgksu2-0 (>= 1.9.6),
libgksuui1.0-1, libglade2-0 (>= 1:2.6.1), libglib2.0-0 (>= 2.14.0), libgnome-keyring0 (>= 2.19.6),
libgnome2-0 (>= 2.17.3), libgnomecanvas2-0 (>= 2.11.1), libgnomeui-0 (>= 2.19.1),
libgnomevfs2-0 (>= 1:2.17.90), libgtk2.0-0 (>= 2.12.0), libgtkspell0 (>= 2.0.2),
libice6 (>= 1:1.0.0), libnspr4-0d (>= 1.8.0.10), liborbit2 (>= 1:2.14.8),
libpango1.0-0 (>= 1.18.2), libpng12-0 (>= 1.2.13-4), libpopt0 (>= 1.10), libsm6,
libstartup-notification0 (>= 0.8-1), libx11-6, libxcomposite1 (>=1:0.3-1),
libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3 (>= 1:4.0.1), libxi6, libxinerama1,
libxml2 (>= 2.6.29), libxrandr2 (>= 2:1.2.0), libxrender1, zlib1g (>= 1:1.2.3.3.dfsg-1),
python-support (>= 0.3.4), python (<< 2.6), python (>= 2.4), python-gtk2,
python-pyorbit, python-gnome2-desktop

O sea: a ba­jar 87M­B. Eso no es­tá bue­no. De he­cho, ca­si no hay cam­bios con res­pec­to a 1.3.1 que no re­que­ría to­do eso! Sal­vo por un cam­bio muy im­por­tan­te en una eeeP­C: se pue­de achi­car la al­tu­ra a 400 pixel­s.

Así que sien­do lo que so­y, hi­ce es­to:

wicd-qt.png

Es un reem­pla­zo de gui.­py y tra­y.­py de wi­cd. Só­lo ne­ce­si­ta Py­Q­t4, que ya lo te­nía ins­tal­do y de­pen­de de:

libc6 (>= 2.6-1), libgcc1 (>= 1:4.2.1), libqt4-core (>= 4.3.2),
libqt4-gui (>= 4.3.2), libstdc++6 (>= 4.2.1), python-central (>= 0.5.8),
python (<< 2.6), python (>= 2.4), python-sip4 (>= 4.7), python-sip4 (<< 4.8)

¿Se ve la di­fe­ren­cia?

Me to­mó unas 3 ho­ras pa­ra ar­mar­lo, y fun­cio­na (ex­cep­to red wi­re­d, dia­lo­go de pre­fe­ren­cia­s, IPs es­tá­ti­cos y scrip­ts) pe­ro lo di­fí­cil es­tá he­cho.

Si al­guien quie­re una co­pia, que pi­da no­má­s. ¿Su­pon­go que KU­bun­tu po­dría usar al­go así?

Snis / 2008-02-06 19:08:

Yes!
Great work, could I please have a copy of the code. The GUI looks alot better than the GTK one.

keep it up!

Roberto Alsina / 2008-02-07 07:15:

I need to hack a couple more things before it's not too ugly to show :-)

O will put it on a googlecode project on a few days.


Contents © 2000-2020 Roberto Alsina